DOWNTIME - FIDELITY BANK DISBURSEMENT

Incident Report for Monnify

Resolved

Disbursement transactions to Fidelity bank are now processing successfully.
Posted Nov 24, 2025 - 11:59 GMT

Investigating

Hi Team,

Please note that we are receiving "System malfunction by destination institution" error from "Fidelity bank".

Disbursements to this bank will be failing at this time.
Posted Nov 24, 2025 - 10:27 GMT
This incident affected: Disbursements.