DOWNTIME - CARD PAYMENTS

Incident Report for Monnify

Resolved

Dear Partners,

We are pleased to inform you that the issue affecting card payment receipts with the card processor (Interswitch) has now been fully resolved, and transactions are processing normally.

Thank you for your patience and understanding.
Posted Nov 26, 2025 - 14:34 GMT

Investigating

Dear Partners,

Kindly be informed that you may experience challenges receiving payments via cards. The issue is currently being investigated with the card processor (Interswitch).

Resolution is ongoing and an update would be provided once available.
Posted Nov 26, 2025 - 12:59 GMT
This incident affected: Payment Collection (Card payments).