DOWNTIME - GTB BANK DISBURSEMENTS

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 22:42 BST

Investigating

Dear Team,

Please note that we are receiving "Transacton timed out while waiting for destination bank" from GTB.

Disbursements to this bank will be failing at this time
Posted Apr 25, 2025 - 15:46 BST
This incident affected: Disbursements.