System Maintenance Affecting Disbursement

Incident Report for Monnify

Resolved

Maintenance is now completed. Pending disbursements have been cleared now.
Posted Mar 04, 2026 - 19:01 GMT

Monitoring

Dear team,

We are experiencing internal pending disbursements at the moment.
Consequently, Merchants may encounter pending/failed transactions when transferring funds from their wallets to other banks.
This is a result of the ongoing system maintenance.

We apologize for any inconvenience this may cause and will keep you informed of our progress.

Thank you for your patience and understanding.
Posted Mar 04, 2026 - 18:37 GMT
This incident affected: Disbursements.