SERVICE DEGRADATION - CARD PAYMENTS

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Oct 12, 2025 - 13:43 BST

Investigating

Dear Team,

We are currently experiencing Intermittent timeouts on our card transactions, which is causing delayed/failed card payments.

These challenges originate from the provider. We are maintaining close contact with them to get updates on the resolution.

We apologize for any inconvenience caused and will provide updates as we receive them.

Thank you for your patience and understanding.
Posted Oct 12, 2025 - 12:24 BST
This incident affected: Payment Collection (Card payments).