DOWNTIME - UNION BANK DISBURSEMENTS

Incident Report for Monnify

Resolved

This incident has been resolved
Posted May 29, 2025 - 22:40 BST

Investigating

Hi Team

We are receiving "System Malfunction from destination bank" and "Beneficiary Bank not available" errors from Union Bank.

Disbursements to this bank will be failing at this time.
Posted May 29, 2025 - 15:41 BST
This incident affected: Disbursements.