NIBSS DIRECT DEBIT TIMEOUT

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 05:36 BST

Identified

Hello team,

We are currently experiencing issues with creating direct debit mandates, which is causing pending or failed mandate requests.
These challenges originate from NIBSS, and we are in close contact with them to get updates on resolution.

We apologize for any inconvenience caused and will provide updates as we receive them.

Thank you for your patience and understanding.
Posted Apr 19, 2026 - 08:58 BST
This incident affected: Payment Collection (Direct Debit).