DOWNTIME - MONNIFY DASHBOARD

Incident Report for Monnify

Resolved

Hi team,

Please note that the issue has been resolved. Merchants should now be able to access their Monnify dashboard without any problems.

Thank you for your patience.
Posted Dec 01, 2025 - 11:51 GMT

Investigating

Dear Partners,

We are sorry to inform you that we're experiencing an issue on the Monnify dashboard, which is affecting access to the merchant web application.

Our technical team is working on this, and updates will be shared on the progress of the resolution as soon as possible.

Thank you for your patience.
Posted Dec 01, 2025 - 08:42 GMT
This incident affected: Merchant Dashboard.