Important Notice: Back-Office Service Issues

Incident Report for Monnify

Resolved

This issue has been resolved
Posted May 15, 2026 - 08:51 BST

Identified

Hello Team,

Please be informed that users may experience issues accessing the back-office. We are currently working to resolve the issue.

Thank you for your understanding, and we sincerely apologize for any inconvenience this may cause.
Posted May 15, 2026 - 08:48 BST