Scheduled system maintenance

Scheduled for Sep 6, 01:00 - 02:30 BST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 05, 2026 - 12:28 BST

Scheduled

Dear Partner,

Please be advised that we will be carrying out an Scheduled system maintenance activity from Monday, September 07, 2026, at 1:00 AM (WAT) to Monday, September 07, 2026, 2:30 AM (WAT) as part of ongoing efforts to enhance stability and reliability of our platform.

During this maintenance window, Disbursements, Virtual Accounts, Direct Debit and Card collections may experience intermittent disruptions for an estimated time of 3-10mins. We will notify you as soon as the maintenance has been successfully completed.

We sincerely apologize for any inconvenience this may cause and appreciate your continued patience and understanding.
Posted Sep 04, 2026 - 14:58 BST
This scheduled maintenance affects: Payment Collection (Virtual account payments, Card payments, Direct Debit) and Disbursements.