DISBURSEMENT DOWNTIME

Incident Report for Monnify

Resolved

Hello team,

This is resolved. Disbursement transactions are now processing successfully, and backlogs will be cleared shortly.

Thank you for your patience.
Posted May 09, 2026 - 02:17 BST

Monitoring

Hello team,

We are currently experiencing issues with one of our transaction processing providers. This is affecting our disbursement service, and as a result, merchants may notice transaction delays (pending status) or failures when transferring funds from their wallets to some external bank accounts.

We are mitigating the impact by rerouting affected transactions through alternative providers to maintain service stability.

We apologize for any inconvenience this may cause. Thank you for your patience.
Posted May 09, 2026 - 01:39 BST
This incident affected: Disbursements.