PALMPAY DOWNTIME

Incident Report for Monnify

Resolved

This issue has been resolved
Posted Apr 11, 2026 - 00:18 BST

Monitoring

Hello team,

Please note that we are receiving "Beneficiary Bank not available" from "PALMPAY"

Disbursements to this bank will be failing at this time
Posted Apr 10, 2026 - 20:26 BST
This incident affected: Disbursements.