NIBSS SERVICE DELAY NOTIFICATION

Incident Report for Monnify

Resolved

This has been resolved.
Posted May 12, 2026 - 22:48 BST

Investigating

Hello team,

We are currently experiencing delayed transaction status confirmations due to an issue from NIBSS. This is affecting our collection providers for transactions carried out via NIP.

The NIBSS technical team is currently working to resolve the issue, while we maintain close communication with the affected providers for updates on resolution timelines.

We apologize for any inconvenience caused and will continue to provide updates as we receive them.

Thank you for your patience and understanding.
Posted May 12, 2026 - 19:08 BST
This incident affected: Payment Collection (Virtual account payments).