NIBSS DD MANDATE ACTIVATION DOWNTIME

Incident Report for Monnify

Resolved

Dear partners,

This is resolved.
Posted May 05, 2026 - 09:26 BST

Monitoring

Dear partners,

We've noticed an improvement in the service. However, we will keep monitoring mandate requests for stability.

We apologize for the inconvenience, and thank you for your patience.
Posted May 05, 2026 - 08:46 BST

Investigating

Dear partners,

Please note that we are experiencing issues with create mandate activation for NIBSS direct debit which is causing pending create mandate requests. These challenges originate from NIBSS, and we are in close contact with them to get it resolved ASAP.

We apologize for any inconvenience caused and will provide updates as we receive them.

Thank you for your patience and understanding.
Posted May 05, 2026 - 05:46 BST
This incident affected: Payment Collection (Direct Debit).