DOWNTIME- KUDA MICROFINANCE BANK

Incident Report for Monnify

Resolved

Hello team,

This has been resolved. Disbursement transactions to Kuda Bank are now processing successfully.
Posted Feb 21, 2026 - 04:48 GMT

Investigating

Hello team,

Please note that we are receiving "Transaction timed out while waiting for destination bank" error from " Kuda Bank"

Disbursements to these banks will be failing at this time.
Posted Feb 21, 2026 - 03:01 GMT
This incident affected: Disbursements.