DOWNTIME - FIDELITY BANK DISBURSEMENT

Incident Report for Monnify

Resolved

Hi team,

This has been resolved; disbursement transactions to Fidelity bank are now processing successfully.
Posted Dec 12, 2025 - 03:00 GMT

Investigating

Hello Team,

We are receiving "System Malfunction by destination Bank" error from "Fidelity Bank."

Disbursements to this bank will be failing at this time
Posted Dec 12, 2025 - 02:23 GMT
This incident affected: Disbursements.