KUDA MFB DOWNTIME

Incident Report for Monnify

Resolved

Hello team,

This is resolved. Disbursement transactions to Kuda MFB are now processing successfully.
Posted Apr 26, 2026 - 06:10 BST

Monitoring

Hello team,

Please note that we are receiving "Timeout waiting for response from destination" from "Kuda bank"

Disbursements to this bank will be failing at this time.
Posted Apr 26, 2026 - 05:21 BST
This incident affected: Disbursements.