Important Service Update: Payout Settlement Delays

Incident Report for Monnify

Resolved

This incident has been resolved
Posted May 14, 2026 - 12:40 BST

Monitoring

Dear Merchants,

We would like to inform you that a temporary service disruption yesterday involving our central processing partner, NIBSS, may have impacted some payout transactions, specifically cases where beneficiaries are yet to receive value.

Please be assured that we are actively working internally and with relevant stakeholders to validate and resolve all affected transactions before close of business today.

We appreciate your patience and will provide further updates as they become available.

Kind regards.
Posted May 13, 2026 - 12:23 BST
This incident affected: Payment Collection (Virtual account payments) and Disbursements.