DOWNTIME- KUDA MICROFINANCE BANK

Incident Report for Monnify

Resolved

Hello team,

This has been resolved. Disbursement transactions to Kuda Bank are now processing successfully.
Posted Feb 17, 2026 - 10:15 GMT

Investigating

Hello team,

Please note that we are receiving "Transaction timed out while waiting for destination bank" error from "Kuda Bank"

Disbursements to these banks will be failing at this time.
Posted Feb 17, 2026 - 09:58 GMT
This incident affected: Disbursements.