DOWNTIME - ACCESS BANK DISBURSEMENT

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 10:20 BST

Investigating

Hi Team

We are receiving "beneficiary bank not available" error from Access bank .

Disbursements to this bank will be failing at this time
Posted Jul 08, 2025 - 07:07 BST
This incident affected: Disbursements.