NIBSS DD DOWNTIME

Incident Report for Monnify

Resolved

This is resolved
Posted Apr 17, 2026 - 14:03 BST

Monitoring

Dear partners,

We are currently experiencing issues with direct debit transactions, which is causing pending/failed debit mandate requests. These challenges originate from NIBSS. We are maintaining close contact with them to get updates on the resolution.

We apologize for any inconvenience caused and will provide updates as we receive them.

Thank you for your patience and understanding.
Posted Apr 16, 2026 - 14:46 BST
This incident affected: Payment Collection (Direct Debit).