DISBURSEMENT HIGH RESPONSE TIME

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Apr 12, 2026 - 11:32 BST

Update

This incident has been resolved.
Posted Apr 12, 2026 - 11:32 BST

Update

Hi Team,

Please be informed that service processing has improved generally in the past 2 hours, however we are still monitoring for stability.

A conclusive update will be communicated accordingly.
Posted Apr 12, 2026 - 09:27 BST

Monitoring

Hello Team,

We are currently experiencing an internal incident that is affecting payments (Disbursement) and is causing failed/pending transactions.

We have escalated the matter to the technical team. We will inform you as soon as the issue is resolved.

Thank you for your understanding and patience.
Posted Apr 12, 2026 - 05:55 BST
This incident affected: Disbursements.