DOWNTIME - FIDELITY BANK PAYMENTS
Incident Report for Monnify
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 21:29 BST
Investigating
Dear Partners,

Fidelity bank is currently unable to receive payments. This affects collections via Fidelity bank accounts as well as disbursements to Fidelity bank account numbers.

This has been escalated to Fidelity Bank.

We are following up with them and will let you know once this is resolved.

Regards,
Posted Apr 16, 2024 - 18:18 BST
This incident affected: Payment Collection (Virtual account payments) and Disbursements.