SERVICE DEGRADATION - DIRECT DEBIT

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Oct 11, 2025 - 13:21 BST

Investigating

Dear Team,

We are currently having timeouts with direct debit transactions, which is causing pending/failed mandate requests.

These challenges originate from NIBSS. We are maintaining close contact with them to get updates on the resolution.

We apologize for any inconvenience caused and will provide updates as we receive them.

Thank you for your patience and understanding.
Posted Oct 11, 2025 - 09:41 BST
This incident affected: Payment Collection (Direct Debit).