DOWNTIME - MONNIFY DASHBOARD

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Oct 19, 2025 - 08:10 BST

Investigating

Dear Partners,

We are sorry to inform you that we're experiencing downtime on the Monnify dashboard, which is affecting access to the merchant web application.

Our technical team is working on this and updates will be shared on the progress of the resolution as soon as possible.

Thank you for your patience.
Posted Oct 19, 2025 - 05:29 BST
This incident affected: Merchant Dashboard.