NIBSS DD DOWNTIME

Incident Report for Monnify

Resolved

Dear partners,

This is resolved. Create mandate requests are now processing successfully.
Posted Apr 22, 2026 - 13:29 BST

Monitoring

Dear partners,

We are currently experiencing issues with creating direct debit mandates, which is causing pending or failed create mandate requests.
These challenges originate from NIBSS, and we are in close contact with them to get updates on resolution.

We apologize for any inconvenience caused and will provide updates as we receive them.

Thank you for your patience and understanding.
Posted Apr 22, 2026 - 10:44 BST
This incident affected: Payment Collection (Direct Debit).