DOWNTIME- MONIEPOINT COLLECTIONS

Incident Report for Monnify

Resolved

This has been resolved.
Posted May 05, 2026 - 03:46 BST

Investigating

Dear partners,

We are currently experiencing issues, causing a delay in receiving some notifications for transactions made to Moniepoint MFB. This affects payments (collections) made via Moniepoint Bank accounts.

These challenges originate from NIBSS. We are maintaining close contact with them to get updates on the resolution. We will inform you as soon as the problem is resolved.

Other providers, including Sterling Bank, Fidelity Bank, GTBank, and Wema, remain fully operational and are available as alternatives.

Thank you for your understanding and patience.
Posted May 04, 2026 - 15:14 BST
This incident affected: Payment Collection (Virtual account payments).