WEMA BANK DOWNTIME

Incident Report for Monnify

Resolved

This has been resolved.
Posted May 03, 2026 - 06:17 BST

Investigating

Hello team

Please note that we are receiving "Timeout waiting for response from destination" from "Wema Bank"

Disbursements to this bank will be failing at this time.
Posted May 03, 2026 - 00:29 BST
This incident affected: Disbursements.