DOWNTIME- STANBIC IBTC BANK

Incident Report for Monnify

Resolved

Hello team,

This is resolved. Disbursement transactions to Stanbic IBTC bank are now processing successfully.
Posted Jul 25, 2026 - 03:03 BST

Monitoring

Dear partners,

Please note that we are receiving "Transaction timed out while waiting for destination bank" from Stanbic IBTC bank

Disbursements to this bank will be failing at this time.
Posted Jul 25, 2026 - 02:55 BST
This incident affected: Disbursements.