DOWNTIME- DIRECT DEBIT

Incident Report for Monnify

Resolved

Dear team,

Please note that this is resolved. Create mandate requests are now processing successfully.
Posted Mar 02, 2026 - 01:06 GMT

Investigating

Dear team,

We are currently experiencing issues with creating direct debit transactions, which is causing pending or failed mandate requests. These challenges originate from NIBSS, and we are in close contact with them to get updates on resolution.

We apologize for any inconvenience caused and will provide updates as we receive them.

Thank you for your patience and understanding.
Posted Mar 02, 2026 - 00:05 GMT
This incident affected: Payment Collection (Direct Debit).