DOWNTIME - GTBANK CARD PAYMENTS
Incident Report for Monnify
Resolved
This incident has been resolved.
Posted Mar 13, 2024 - 10:08 GMT
Investigating
Dear Partners,

Kindly be informed that you may experience challenges receiving payments via cards. The issue is currently being investigated with the card processor.

Resolution is ongoing and an update would be provided once available.
Posted Mar 13, 2024 - 06:58 GMT
This incident affected: Payment Collection (Card payments).