CLOUDFLARE DOWNTIME

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 13:03 GMT

Monitoring

Please note that our platforms have fully recovered, and all services are now operating normally.
We will continue to monitor systems closely to ensure stable performance.
Thank you for your patience and understanding.
Posted Dec 05, 2025 - 09:46 GMT

Investigating

Hello team,
We are experiencing a global outage that is affecting multiple platforms due to a Cloudflare outage.
We apologize for the inconvenience and will provide updates as soon as more information becomes available.
Thank you for your understanding.
Posted Dec 05, 2025 - 09:15 GMT
This incident affected: Payment Collection (Virtual account payments, Card payments, Direct Debit) and Disbursements.