DOWNTIME - ZENITH BANK DISBURSEMENT

Incident Report for Monnify

Resolved

Disbursement transactions to zenith bank are processing fine.
Posted May 27, 2025 - 04:45 BST

Investigating

Hi Team

We are receiving "Transaction timed out while waiting for destination bank" from Zenith bank .

Disbursements to this bank will be failing at this time.
Posted May 27, 2025 - 03:27 BST
This incident affected: Disbursements.