DOWNTIME - FIDELITY BANK DISBURSEMENT

Incident Report for Monnify

Resolved

Dear Partner,

Please be advised that transactions to Fidelity bank can now resume as we have confirmed that their service is now up and running.

Thank you for your patience.
Posted Dec 03, 2025 - 02:16 GMT

Investigating

Hi Team,

Please note that we are receiving " Transaction timed out while waiting for destination bank " error from "Fidelity bank".

Disbursements to this bank will be failing at this time.
Posted Dec 03, 2025 - 00:58 GMT
This incident affected: Disbursements.