DOWNTIME - GTBANK CARD PAYMENTS
Incident Report for Monnify
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 06:48 GMT
Identified
Dear Partners,

Kindly be informed that there may be challenges in processing payments made with GTBank cards. We have escalated the issue to the card processor and are actively pursuing a swift resolution.

We appreciate your patience and understanding. In the meantime, all our alternative payment channels remain operational.

Best Regards,
Posted Mar 18, 2024 - 18:09 GMT
This incident affected: Payment Collection (Card payments).