NIBSS - HIGH RESPONSE TIME

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Mar 23, 2025 - 03:24 GMT

Update

We are continuing to investigate this issue.
Posted Mar 23, 2025 - 01:15 GMT

Investigating

Dear Team,

We are encountering a high response time with the central transfer processor for banks (NIBSS), which is affecting our disbursement service. Consequently, you may experience delays (pending disbursements) when attempting to transfer funds from your wallet to other bank accounts.

These challenges are originating from NIBSS. We are maintaining close contact with them to get updates on the resolution.
We apologize for any inconvenience caused and will provide updates as we receive them.

Thank you for your patience and understanding.
Posted Mar 23, 2025 - 01:15 GMT
This incident affected: Disbursements.