DISBURSEMENTS - STANBIC IBTC BANK

Incident Report for Monnify

Resolved

This has been resolved.
Posted Feb 23, 2026 - 06:52 GMT

Investigating

Hello team,

Please note that we are receiving "Transaction timed out while waiting for destination bank " Stanbic IBTC Bank"

Disbursements to this bank will be failing at this time.
Posted Feb 23, 2026 - 05:23 GMT
This incident affected: Disbursements.