DOWNTIME - FIRST BANK DISBURSEMENT

Incident Report for Monnify

Resolved

Hello Team,
We are routing through another provider. First Bank is now processing successfully.
Posted Apr 11, 2026 - 01:19 BST

Monitoring

Hello team,

Please note that we are receiving "Beneficiary Bank not available" from "First Bank"

Disbursements to this bank will be failing at this time
Posted Apr 10, 2026 - 22:46 BST
This incident affected: Disbursements.