DOWNTIME - KUDA MFB DISBURSEMENTS

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 14:07 GMT

Investigating

Hi Team,

Please note that we are receiving "Beneficiary bank not available " from kuda Microfinance bank .

Disbursements to this bank will be failing at this time.
Posted Mar 26, 2025 - 14:10 GMT
This incident affected: Disbursements.