Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 31, 2025 - 01:00 BST
Update
Dear Partner,
We wish to inform you of a scheduled system maintenance on Sunday, August 31, 2025, from 1:00 AM to 1:30 AM (GMT+1).
This exercise is necessary to strengthen system stability and ensure consistent performance across all our services.
Expected impact:
1. All services will remain available throughout the maintenance window. 2. A brief performance slowdown may occur, lasting no longer than 5 minutes. 3. No full downtime is expected.
We will notify you immediately once the maintenance has been successfully completed.
Thank you for your understanding and continued partnership.
Posted Aug 30, 2025 - 08:22 BST
Scheduled
Dear Partners,
Please note that there will be a brief system maintenance on Sunday, August 31st, 2025, from 1:00 AM to 2:00 AM.
During this time, disbursement and external account settlement transactions may experience delays or eventual failures.
We apologize for any inconvenience and appreciate your patience. Updates will be shared once the maintenance is complete.
Thank you for your understanding.
Posted Aug 30, 2025 - 08:21 BST
This scheduled maintenance affected: Disbursements.