DOWNTIME- GTB CARD COLLECTIONS

Incident Report for Monnify

Resolved

Hello team,

This is resolved. GTB card transactions are now processing successfully.
Posted Mar 04, 2026 - 10:16 GMT

Investigating

Dear team,

Please note that we are currently experiencing timeouts for GTB card transactions, which is causing failed card payments. This is being reviewed with the technical team and an update will be shared as soon as possible.

We apologize for any inconvenience caused.

Thank you for your patience and understanding
Posted Mar 04, 2026 - 08:51 GMT
This incident affected: Payment Collection (Card payments).