DOWNTIME - UNION BANK

Incident Report for Monnify

Resolved

This incident has been resolved
Posted Apr 25, 2025 - 15:51 BST

Investigating

Dear Team,

Please note that we are receiving "Beneficiary Bank not available" from UNION Bank

Disbursements to this bank will be failing at this time.
Posted Apr 25, 2025 - 13:45 BST
This incident affected: Disbursements.