DISBURSEMENT DOWNTIME

Incident Report for Monnify

Resolved

Hello team,

This has been resolved. Disbursement transactions are now processing successfully.

Thank you for your patience and understanding.
Posted Apr 16, 2026 - 09:13 BST

Investigating

Dear partners,

We are currently managing an internal incident that is affecting a subset of payments (Disbursement) and is causing failed/pending transactions.

We are working with relevant stakeholders to restore overall experience and we will communicate progressive updates in due time.

Thank you for your understanding and patience.
Posted Apr 13, 2026 - 00:23 BST
This incident affected: Disbursements.