DOWNTIME - WEMA BANK TRANSACTION PROCESSING

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 20:47 GMT

Investigating

Hello Team,

We are currently experiencing difficulties in transactions processing to Wema Bank. Consequently, you may encounter "Beneficiary bank unavailable" for disbursement transactions or you may encounter delays in receiving notifications or validating accounts for incoming transactions.

We have escalated the matter to Wema bank and are actively following up with them. We will inform you as soon as the issue is resolved.

Other collection providers, including Sterling Bank, Fidelity Bank, GTBank and Moniepoint MFB, remain fully operational and are available as alternatives.

Thank you for your understanding and patience.
Posted Dec 04, 2025 - 14:03 GMT
This incident affected: Payment Collection (Virtual account payments) and Disbursements.