DOWNTIME - DISBURSEMENT TO PAYCOM (OPAY)

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Apr 19, 2025 - 13:33 BST

Investigating

Dear Partner,

Please note that we are receiving "Beneficiary Bank not available" error from Opay.

Disbursements to this bank will be failing at this time.
Posted Apr 19, 2025 - 10:21 BST
This incident affected: Disbursements.