SERVICE DEGRADATION - CARD PAYMENTS

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Dec 07, 2025 - 03:24 GMT

Investigating

Dear Partner,

We are currently having intermittent timeouts for card transactions, which is causing failed card payments.

These challenges originate from our provider. We are maintaining close contact with them to get updates on the resolution.

We apologize for any inconvenience caused and will provide updates as we receive them.

Thank you for your patience and understanding.
Posted Dec 07, 2025 - 02:22 GMT
This incident affected: Payment Collection (Card payments).