ZENITH BANK DOWNTIME

Incident Report for Monnify

Resolved

This has been resolved.
Posted May 28, 2026 - 00:33 BST

Identified

Hello team,

Please note that we are receiving "Transaction timed out while waiting for destination bank" from Zenith Bank

Disbursements to this bank will be failing at this time.
Posted May 28, 2026 - 00:25 BST
This incident affected: Disbursements.