DOWNTIME - UNION BANK DISBURSEMENT

Incident Report for Monnify

Resolved

This incident has been resolved.
Posted Mar 30, 2025 - 10:45 BST

Monitoring

Dear partners,

Please note that we are receiving "Beneficiary bank not available" from Union bank .

Disbursements to this bank will be failing at this time
Posted Mar 29, 2025 - 14:59 GMT
This incident affected: Disbursements.