NIBSS - DOWNTIME

Incident Report for Monnify

Resolved

This has been resolved and disbursements are now processing fine.
Posted Mar 27, 2025 - 15:29 GMT

Investigating

Dear Partners,

We are encountering issues with the central transfer processor for banks (NIBSS), which is affecting our disbursement service. Consequently, merchants may experience delays (pending disbursements) and failures when transferring funds from their wallets to other bank accounts.

These challenges are originating from our connection with NIBSS. We are maintaining close contact with them to get updates on the resolution. We are mitigating this challenge by routing transactions via other providers.

We apologize for any inconvenience caused and will provide updates as we receive them.
Posted Mar 27, 2025 - 15:00 GMT
This incident affected: Disbursements.